How to install OpenStack Grizzly(All in One) on RHEL 6.4

 

Pre-requirements:

- Internet connection

- Red Hat Account to download packages or available repository to get

- RHEL 6.4 ISO Image

 

1- Install RHEL 6.4 with minimum installation package group(+ openssh-clients and ntpd packages)

2. Install Puppet repo rpm package
(root)# yum install -y http://yum.puppetlabs.com/el/6/products/i386/puppetlabs-release-6-7.noarch.rpm

3. Install Grizzly repository package
(root)#yum install -y http://rdo.fedorapeople.org/openstack-grizzly/rdo-release-grizzly.rpm

4. Update repositories
(root)#yum check-update
[root@openstackserver repos]# yum check-update
Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
openstack-grizzly                                                                                            | 2.9 kB     00:00     
openstack-grizzly/primary_db                                                                                 | 972 kB     00:03     
puppetlabs-deps                                                                                              | 1.9 kB     00:00     
puppetlabs-deps/primary_db                                                                                   |  21 kB     00:00     
puppetlabs-products                                                                                          | 1.9 kB     00:00     
puppetlabs-products/primary_db                                                                               |  98 kB     00:00     

iproute.x86_64                                       2.6.32-130.el6ost.netns.2                                     openstack-grizzly
iputils.x86_64                                       20071127-17.el6_4                                             openstack-grizzly
kernel.x86_64                                        2.6.32-358.123.2.openstack.el6                                openstack-grizzly
kernel-firmware.noarch                               2.6.32-358.123.2.openstack.el6                                openstack-grizzly

5. Download “rubygems-1.8.16-1.el6.noarch” from Red Hat and upload under /root
6. Create a repository which uses RHEL 6.4 ISO image. If you dont know how to do it, check here
7. Install “rubygems” package
(root)#yum install -y /root/rubygems-1.8.16-1.el6.noarch
8. Now instally “puppet”. It will download necessary packages from repositories and then install them
[root@openstackserver packages]# yum install -y puppet
Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
–> Running transaction check
—> Package puppet.noarch 0:3.3.1-1.el6 will be installed
–> Processing Dependency: facter >= 1.6.11 for package: puppet-3.3.1-1.el6.noarch
–> Processing Dependency: ruby-rgen >= 0.6.5 for package: puppet-3.3.1-1.el6.noarch
–> Processing Dependency: hiera >= 1.0.0 for package: puppet-3.3.1-1.el6.noarch
–> Processing Dependency: ruby-augeas for package: puppet-3.3.1-1.el6.noarch
–> Processing Dependency: ruby-shadow for package: puppet-3.3.1-1.el6.noarch
–> Processing Dependency: ruby(selinux) for package: puppet-3.3.1-1.el6.noarch
–> Running transaction check
—> Package facter.x86_64 1:1.7.3-1.el6 will be installed
—> Package hiera.noarch 0:1.2.1-1.el6 will be installed
–> Processing Dependency: rubygem-json for package: hiera-1.2.1-1.el6.noarch
—> Package libselinux-ruby.x86_64 0:2.0.94-5.3.el6 will be installed
—> Package ruby-augeas.x86_64 0:0.4.1-1.el6 will be installed
–> Processing Dependency: augeas-libs >= 0.8.0 for package: ruby-augeas-0.4.1-1.el6.x86_64
–> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
–> Processing Dependency: libaugeas.so.0(AUGEAS_0.12.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
–> Processing Dependency: libaugeas.so.0(AUGEAS_0.11.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
–> Processing Dependency: libaugeas.so.0(AUGEAS_0.10.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
–> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
–> Processing Dependency: libaugeas.so.0()(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
—> Package ruby-rgen.noarch 0:0.6.5-1.el6 will be installed
—> Package ruby-shadow.x86_64 0:1.4.1-13.el6 will be installed
–> Running transaction check
—> Package augeas-libs.x86_64 0:0.9.0-4.el6 will be installed
—> Package rubygem-json.x86_64 0:1.5.5-1.el6 will be installed
–> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================
 Package                         Arch                   Version                           Repository                           Size
====================================================================================================================================
Installing:
 puppet                          noarch                 3.3.1-1.el6                       puppetlabs-products                 1.1 M
Installing for dependencies:
 augeas-libs                     x86_64                 0.9.0-4.el6                       rhel-dvd                            317 k
 facter                          x86_64                 1:1.7.3-1.el6                     puppetlabs-products                  85 k
 hiera                           noarch                 1.2.1-1.el6                       puppetlabs-products                  21 k
 libselinux-ruby                 x86_64                 2.0.94-5.3.el6                    rhel-dvd                             99 k
 ruby-augeas                     x86_64                 0.4.1-1.el6                       puppetlabs-deps                      21 k
 ruby-rgen                       noarch                 0.6.5-1.el6                       puppetlabs-deps                      87 k
 ruby-shadow                     x86_64                 1.4.1-13.el6                      puppetlabs-deps                      11 k
 rubygem-json                    x86_64                 1.5.5-1.el6                       puppetlabs-deps                     763 k

Transaction Summary
====================================================================================================================================
Install       9 Package(s)

Total download size: 2.5 M
Installed size: 6.3 M
Downloading Packages:
(2/9): facter-1.7.3-1.el6.x86_64.rpm                                                                         |  85 kB     00:00     
(3/9): hiera-1.2.1-1.el6.noarch.rpm                                                                          |  21 kB     00:00     
(5/9): puppet-3.3.1-1.el6.noarch.rpm                                                                         | 1.1 MB     00:10     
(6/9): ruby-augeas-0.4.1-1.el6.x86_64.rpm                                                                    |  21 kB     00:00     
(7/9): ruby-rgen-0.6.5-1.el6.noarch.rpm                                                                      |  87 kB     00:00     
(8/9): ruby-shadow-1.4.1-13.el6.x86_64.rpm                                                                   |  11 kB     00:00     
(9/9): rubygem-json-1.5.5-1.el6.x86_64.rpm                                                                   | 763 kB     00:07     
————————————————————————————————————————————
Total                                                                                               125 kB/s | 2.5 MB     00:20     
warning: rpmts_HdrFromFdno: Header V4 RSA/SHA1 Signature, key ID 4bd6ec30: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-puppetlabs
Importing GPG key 0x4BD6EC30:
 Userid : Puppet Labs Release Key (Puppet Labs Release Key) <info@puppetlabs.com>
 Package: puppetlabs-release-6-7.noarch (@/puppetlabs-release-6-7.noarch)
 From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-puppetlabs
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : ruby-shadow-1.4.1-13.el6.x86_64                                                                                  1/9
  Installing : rubygem-json-1.5.5-1.el6.x86_64                                                                                  2/9
  Installing : hiera-1.2.1-1.el6.noarch                                                                                         3/9
  Installing : ruby-rgen-0.6.5-1.el6.noarch                                                                                     4/9
  Installing : 1:facter-1.7.3-1.el6.x86_64                                                                                      5/9
  Installing : libselinux-ruby-2.0.94-5.3.el6.x86_64                                                                            6/9
  Installing : augeas-libs-0.9.0-4.el6.x86_64                                                                                   7/9
  Installing : ruby-augeas-0.4.1-1.el6.x86_64                                                                                   8/9
  Installing : puppet-3.3.1-1.el6.noarch                                                                                        9/9
  Verifying  : augeas-libs-0.9.0-4.el6.x86_64                                                                                   1/9
  Verifying  : ruby-augeas-0.4.1-1.el6.x86_64                                                                                   2/9
  Verifying  : libselinux-ruby-2.0.94-5.3.el6.x86_64                                                                            3/9
  Verifying  : 1:facter-1.7.3-1.el6.x86_64                                                                                      4/9
  Verifying  : ruby-rgen-0.6.5-1.el6.noarch                                                                                     5/9
  Verifying  : hiera-1.2.1-1.el6.noarch                                                                                         6/9
  Verifying  : puppet-3.3.1-1.el6.noarch                                                                                        7/9
  Verifying  : rubygem-json-1.5.5-1.el6.x86_64                                                                                  8/9
  Verifying  : ruby-shadow-1.4.1-13.el6.x86_64                                                                                  9/9

Installed:
  puppet.noarch 0:3.3.1-1.el6                                                                                                       

Dependency Installed:
  augeas-libs.x86_64 0:0.9.0-4.el6                facter.x86_64 1:1.7.3-1.el6               hiera.noarch 0:1.2.1-1.el6            
  libselinux-ruby.x86_64 0:2.0.94-5.3.el6         ruby-augeas.x86_64 0:0.4.1-1.el6          ruby-rgen.noarch 0:0.6.5-1.el6        
  ruby-shadow.x86_64 0:1.4.1-13.el6               rubygem-json.x86_64 0:1.5.5-1.el6        

Complete!

9. Install “openstack-packstack” package
[root@openstackserver packages]#  yum install -y openstack-packstack
Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
–> Running transaction check
—> Package openstack-packstack.noarch 0:2013.1.1-0.29.dev683.el6 will be installed
–> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================================
 Package                          Arch                Version                                  Repository                      Size
====================================================================================================================================
Installing:
 openstack-packstack              noarch              2013.1.1-0.29.dev683.el6                 openstack-grizzly              602 k

Transaction Summary
====================================================================================================================================
Install       1 Package(s)

Total download size: 602 k
Installed size: 1.8 M
Downloading Packages:
openstack-packstack-2013.1.1-0.29.dev683.el6.noarch.rpm                                                      | 602 kB     00:04     
warning: rpmts_HdrFromFdno: Header V4 RSA/SHA1 Signature, key ID d97b3247: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-RDO-Grizzly
Importing GPG key 0xD97B3247:
 Userid : rdo-grizzly-sign <rdo-info@redhat.com>
 Package: rdo-release-grizzly-3.noarch (@/rdo-release-grizzly-3.noarch)
 From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-RDO-Grizzly
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : openstack-packstack-2013.1.1-0.29.dev683.el6.noarch                                                              1/1
  Verifying  : openstack-packstack-2013.1.1-0.29.dev683.el6.noarch                                                              1/1

Installed:
  openstack-packstack.noarch 0:2013.1.1-0.29.dev683.el6                                                                             

Complete!

10. Now, lets check new packages available on repos if any.
(root)#yum check-update
Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.

iproute.x86_64                                       2.6.32-130.el6ost.netns.2                                     openstack-grizzly
iputils.x86_64                                       20071127-17.el6_4                                             openstack-grizzly
kernel.x86_64                                        2.6.32-358.123.2.openstack.el6                                openstack-grizzly
kernel-firmware.noarch                               2.6.32-358.123.2.openstack.el6                                openstack-grizzly

11. Update packages. It may take some time to download new packages depending on connection speed etc.
(root)#yum update -y

12. Install OpenStack Grizzly on RHEL 6.4. During installation, installer will download missing packages from repositories. so it may take some time to install.
If you want to download all necessary packages prior to installing Open Stack, you can see list of all available packages(at the end of this post) after installation is completed.
You may download these packages to avoid downloading every time you install Open Stack
(root)#packstack –allinone
Clean Up…                                            [ DONE ]
Adding pre install manifest entries…                 [ DONE ]
Setting up ssh keys…root@192.168.1.10′s password:
                                 [ DONE ]
Adding MySQL manifest entries…                       [ DONE ]
Adding QPID manifest entries…                        [ DONE ]
Adding Keystone manifest entries…                    [ DONE ]
Adding Glance Keystone manifest entries…             [ DONE ]
Adding Glance manifest entries…                      [ DONE ]
Adding Cinder Keystone manifest entries…             [ DONE ]
Installing dependencies for Cinder…                  [ DONE ]
Checking if the Cinder server has a cinder-volumes vg…[ DONE ]
Adding Cinder manifest entries…                      [ DONE ]
Adding Nova API manifest entries…                    [ DONE ]
Adding Nova Keystone manifest entries…               [ DONE ]
Adding Nova Cert manifest entries…                   [ DONE ]
Adding Nova Conductor manifest entries…              [ DONE ]
Adding Nova Compute manifest entries…                [ DONE ]
Adding Nova Scheduler manifest entries…              [ DONE ]
Adding Nova VNC Proxy manifest entries…              [ DONE ]
Adding Nova Common manifest entries…                 [ DONE ]
Adding Openstack Network-related Nova manifest entries…[ DONE ]
Adding Quantum API manifest entries…                 [ DONE ]
Adding Quantum Keystone manifest entries…            [ DONE ]
Adding Quantum L3 manifest entries…                  [ DONE ]
Adding Quantum L2 Agent manifest entries…            [ DONE ]
Adding Quantum DHCP Agent manifest entries…          [ DONE ]
Adding Quantum Metadata Agent manifest entries…      [ DONE ]
Adding OpenStack Client manifest entries…            [ DONE ]
Adding Horizon manifest entries…                     [ DONE ]
Adding Swift Keystone manifest entries…              [ DONE ]
Adding Swift builder manifest entries…               [ DONE ]
Adding Swift proxy manifest entries…                 [ DONE ]
Adding Swift storage manifest entries…               [ DONE ]
Adding Swift common manifest entries…                [ DONE ]
Preparing servers…                                   [ DONE ]
Adding post install manifest entries…                [ DONE ]
Installing Dependencies…                             [ DONE ]
Copying Puppet modules and manifests…                [ DONE ]
Applying Puppet manifests…
Applying 192.168.1.10_prescript.pp
192.168.1.10_prescript.pp :                                        [ DONE ]
Applying 192.168.1.10_mysql.pp
Applying 192.168.1.10_qpid.pp
192.168.1.10_mysql.pp :                                            [ DONE ]
192.168.1.10_qpid.pp :                                             [ DONE ]
Applying 192.168.1.10_keystone.pp
Applying 192.168.1.10_glance.pp
Applying 192.168.1.10_cinder.pp
192.168.1.10_keystone.pp :                                         [ DONE ]
192.168.1.10_glance.pp :                                           [ DONE ]
192.168.1.10_cinder.pp :                                           [ DONE ]
Applying 192.168.1.10_api_nova.pp
192.168.1.10_api_nova.pp :                                         [ DONE ]
Applying 192.168.1.10_nova.pp
192.168.1.10_nova.pp :                                             [ DONE ]
Applying 192.168.1.10_quantum.pp
192.168.1.10_quantum.pp :                                          [ DONE ]
Applying 192.168.1.10_osclient.pp
Applying 192.168.1.10_horizon.pp
192.168.1.10_osclient.pp :                                         [ DONE ]
192.168.1.10_horizon.pp :                                          [ DONE ]
Applying 192.168.1.10_ring_swift.pp
192.168.1.10_ring_swift.pp :                                       [ DONE ]
Applying 192.168.1.10_swift.pp
192.168.1.10_swift.pp :                                            [ DONE ]
Applying 192.168.1.10_postscript.pp
192.168.1.10_postscript.pp :                                       [ DONE ]
                           [ DONE ]

 **** Installation completed successfully ******

Additional information:
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * To use the command line tools you need to source the file /root/keystonerc_admin created on 192.168.1.10
 * To use the console, browse to http://192.168.1.10/dashboard
 * The installation log file is available at: /var/tmp/packstack/20131022-174839-CvBnm3/openstack-setup.log

List of installed packages on the system after Open Stack Grizzly Installation
# rpm -qa

nagios-3.5.1-1.el6.x86_64
ipw2200-firmware-3.1-4.el6.noarch
tzdata-2012j-1.el6.noarch
puppet-3.3.1-1.el6.noarch
gpg-pubkey-d97b3247-51641266
glibc-common-2.12-1.107.el6.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
perl-Module-Pluggable-3.90-129.el6.x86_64
bash-4.1.2-14.el6.x86_64
nagios-plugins-nrpe-2.14-3.el6.x86_64
python-iso8601-0.1.4-2.el6.noarch
info-4.13a-8.el6.x86_64
bridge-utils-1.2-10.el6.x86_64
MySQL-python-1.2.3-0.3.c1.1.el6.x86_64
libcom_err-1.41.12-14.el6.x86_64
tuned-0.2.19-11.el6.noarch
python-routes1.12-1.12.3-4.el6.noarch
libsepol-2.0.41-4.el6.x86_64
iproute-2.6.32-130.el6ost.netns.2.x86_64
Django14-1.4.8-1.el6.noarch
shadow-utils-4.1.4.2-13.el6.x86_64
python-swiftclient-1.4.0-1.el6.noarch
dbus-libs-1.2.24-7.el6_3.x86_64
python-amqplib-0.6.1-2.el6.noarch
xz-libs-4.999.9-0.3.beta.20091007git.el6.x86_64
python-anyjson-0.3.1-1.el6.noarch
libidn-1.18-2.el6.x86_64
python-kombu-1.1.3-1.el6.noarch
expat-2.0.1-11.el6_2.x86_64
perl-hivex-1.3.3-4.2.el6.x86_64
grep-2.6.3-3.el6.x86_64
rsync-3.0.6-9.el6.x86_64
elfutils-libelf-0.152-1.el6.x86_64
libaio-0.3.107-10.el6.x86_64
libselinux-utils-2.0.94-5.3.el6.x86_64
python-ldap-2.3.10-1.el6.x86_64
libedit-2.11-4.20080712cvs.1.el6.x86_64
fuse-libs-2.8.3-4.el6.x86_64
libnl-1.1-14.el6.x86_64
python-keyring-0.7-1.el6.noarch
device-mapper-persistent-data-0.1.4-1.el6.x86_64
python-ordereddict-1.1-2.el6.noarch
gmp-4.3.1-7.el6_2.2.x86_64
python-crypto-2.0.1-22.el6.x86_64
libgudev1-147-2.46.el6.x86_64
libpng-1.2.49-1.el6_2.x86_64
MAKEDEV-3.24-6.el6.x86_64
gnutls-2.8.5-10.el6.x86_64
tar-1.23-11.el6.x86_64
python-quantumclient-2.2.1-2.el6.noarch
pinentry-0.7.6-6.el6.x86_64
netcf-libs-0.1.9-3.el6.x86_64
which-2.19-6.el6.x86_64
php-cli-5.3.3-22.el6.x86_64
less-436-10.el6.x86_64
rpcbind-0.2.0-11.el6.x86_64
cracklib-dicts-2.8.16-4.el6.x86_64
celt051-0.5.1.3-0.el6.x86_64
hwdata-0.233-7.9.el6.noarch
python-nose-0.10.4-3.1.el6.noarch
logrotate-3.7.8-16.el6.x86_64
perl-Config-General-2.44-1.el6.noarch
nss-tools-3.14.0.0-12.el6.x86_64
fuse-2.8.3-4.el6.x86_64
ethtool-3.5-1.el6.x86_64
mailcap-2.1.31-2.el6.noarch
openssl-1.0.0-27.el6.x86_64
scrub-2.2-1.el6.x86_64
gpgme-1.1.8-3.el6.x86_64
python-paste-deploy1.5-1.5.0-5.el6.noarch
bind-libs-9.8.2-0.17.rc1.el6.x86_64
mailx-12.4-6.el6.x86_64
ustr-1.0.4-9.1.el6.x86_64
python-beaker-1.3.1-6.el6.noarch
gdbm-1.8.0-36.el6.x86_64
libsysfs-2.1.0-7.el6.x86_64
python-iniparse-0.3.1-2.1.el6.noarch
python-cheetah-2.4.1-1.el6.x86_64
python-ethtool-0.6-3.el6.x86_64
python-suds-0.4.1-3.el6.noarch
libxml2-python-2.7.6-8.el6_3.4.x86_64
polkit-0.96-2.el6_0.1.x86_64
python-dateutil-1.4.1-6.el6.noarch
hal-info-20090716-3.1.el6.noarch
python-urlgrabber-3.9.1-8.el6.noarch
ruby-rgen-0.6.5-1.el6.noarch
rhn-client-tools-1.0.0.1-4.el6.noarch
rubygems-1.8.16-1.el6.noarch
redhat-release-server-6Server-6.4.0.4.el6.x86_64
ruby-shadow-1.4.1-13.el6.x86_64
sg3_utils-libs-1.28-4.el6.x86_64
device-mapper-libs-1.02.77-9.el6.x86_64
libXau-1.0.6-4.el6.x86_64
device-mapper-event-1.02.77-9.el6.x86_64
keyutils-1.4-4.el6.x86_64
kbd-1.15-11.el6.x86_64
python-netifaces-0.5-1.el6.x86_64
ntpdate-4.2.4p8-3.el6.x86_64
python-boto-2.13.3-1.el6.noarch
cronie-anacron-1.4.4-7.el6.x86_64
python-versiontools-1.9.1-3.el6.noarch
rhnsd-4.9.3-2.el6.x86_64
python-decorator-3.0.1-3.1.el6.noarch
iptables-ipv6-1.4.7-9.el6.x86_64
python-configobj-4.6.0-3.el6.noarch
kernel-2.6.32-358.el6.x86_64
libvirt-client-0.10.2-18.el6.x86_64
subscription-manager-1.1.23-1.el6.x86_64
libX11-1.5.0-4.el6.x86_64
openssh-clients-5.3p1-84.1.el6.x86_64
pulseaudio-libs-0.9.21-14.el6_3.x86_64
iwl100-firmware-39.31.5.1-1.el6.noarch
python-six-1.1.0-2.el6.noarch
aic94xx-firmware-30-2.el6.noarch
python-glanceclient-0.9.0-3.el6.noarch
authconfig-6.1.12-13.el6.x86_64
python-markupsafe-0.9.2-4.el6.x86_64
man-1.6f-32.el6.x86_64
python-tempita-0.4-2.el6.noarch
at-3.1.10-43.el6_2.1.x86_64
python-glance-2013.1.3-1.el6.noarch
dbus-1.2.24-7.el6_3.x86_64
usbredir-0.5.1-1.el6.x86_64
lsof-4.82-4.el6.x86_64
libvirt-0.10.2-18.el6.x86_64
traceroute-2.0.14-2.el6.x86_64
python-libguestfs-1.16.34-2.el6.x86_64
iwl5000-firmware-8.83.5.1_1-1.el6_1.1.noarch
openstack-nova-api-2013.1.3-2.el6.noarch
xorg-x11-drv-ati-firmware-6.99.99-1.el6.noarch
openstack-nova-novncproxy-2013.1.3-2.el6.noarch
iwl4965-firmware-228.61.2.24-2.1.el6.noarch
openstack-keystone-2013.1.3-2.el6.noarch
rt73usb-firmware-1.8-7.el6.noarch
libgcc-4.4.7-3.el6.x86_64
ql23xx-firmware-3.03.27-3.1.el6.noarch
filesystem-2.4.30-3.el6.x86_64
rootfiles-8.1-6.1.el6.noarch
basesystem-10.0-4.el6.noarch
rdo-release-grizzly-3.noarch
ncurses-base-5.7-3.20090208.el6.x86_64
perl-Pod-Escapes-1.04-129.el6.x86_64
nss-softokn-freebl-3.12.9-11.el6.x86_64
perl-version-0.77-129.el6.x86_64
ncurses-libs-5.7-3.20090208.el6.x86_64
perl-Pod-Simple-3.13-129.el6.x86_64
libattr-2.4.44-7.el6.x86_64
python-setuptools-0.6.10-3.el6.noarch
zlib-1.2.3-29.el6.x86_64
python-webob-1.2.3-4.el6.noarch
audit-libs-2.2-2.el6.x86_64
python-prettytable-0.6.1-1.el6.noarch
chkconfig-1.3.49.3-2.el6.x86_64
python-argparse-1.2.1-2.el6.noarch
libacl-2.2.49-6.el6.x86_64
python-httplib2-0.7.7-1.el6.noarch
nspr-4.9.2-1.el6.x86_64
python-greenlet-0.3.1-12.el6.x86_64
libselinux-2.0.94-5.3.el6.x86_64
iputils-20071127-17.el6_4.x86_64
libgssglue-0.1-11.el6.x86_64
gamin-0.1.10-9.el6.x86_64
libogg-1.1.4-2.1.el6.x86_64
sed-4.2.1-10.el6.x86_64
python-websockify-0.4.1-1.el6.noarch
readline-6.0-4.el6.x86_64
apr-1.3.9-5.el6_2.x86_64
bzip2-libs-1.0.5-7.el6_0.x86_64
nagios-common-3.5.1-1.el6.x86_64
libudev-147-2.46.el6.x86_64
augeas-libs-0.9.0-4.el6.x86_64
libstdc++-4.4.7-3.el6.x86_64
python-netaddr-0.7.5-4.el6.noarch
cyrus-sasl-lib-2.1.23-13.el6_3.1.x86_64
libjpeg-turbo-1.2.1-1.el6.x86_64
gawk-3.1.7-10.el6.x86_64
numactl-2.0.7-6.el6.x86_64
tcp_wrappers-libs-7.6-57.el6.x86_64
nagios-plugins-1.4.16-5.el6.x86_64
libuuid-2.17.2-12.9.el6.x86_64
libtirpc-0.2.1-5.el6.x86_64
pcre-7.8-6.el6.x86_64
hivex-1.3.3-4.2.el6.x86_64
bzip2-1.0.5-7.el6_0.x86_64
libICE-1.0.6-1.el6.x86_64
findutils-4.4.2-6.el6.x86_64
freetype-2.3.11-6.el6_2.9.x86_64
libgpg-error-1.7-4.el6.x86_64
dnsmasq-2.48-13.el6.x86_64
psmisc-22.6-15.el6_0.1.x86_64
lzo-2.03-3.1.el6.x86_64
checkpolicy-2.0.22-1.el6.x86_64
libibverbs-1.1.6-5.el6.x86_64
cpio-2.10-11.el6_3.x86_64
python-memcached-1.43-6.el6.noarch
libcap-ng-0.6.4-3.el6_0.1.x86_64
libgfortran-4.4.7-3.el6.x86_64
sysvinit-tools-2.87-4.dsf.el6.x86_64
libpcap-1.0.0-6.20091201git117cb5.el6.x86_64
pth-2.0.7-9.3.el6.x86_64
libcgroup-0.37-7.el6.x86_64
grubby-7.0.15-3.el6.x86_64
libxslt-1.1.26-2.el6_3.1.x86_64
tcp_wrappers-7.6-57.el6.x86_64
python-jsonschema-1.3.0-1.el6.noarch
nss-softokn-3.12.9-11.el6.x86_64
iscsi-initiator-utils-6.2.0.873-2.el6.x86_64
libusb-0.1.12-23.el6.x86_64
pyxattr-0.5.0-1.el6.x86_64
xz-lzma-compat-4.999.9-0.3.beta.20091007git.el6.x86_64
python-paramiko-1.7.5-2.1.el6.noarch
libnih-1.0.1-7.el6.x86_64
boost-filesystem-1.41.0-11.el6_1.2.x86_64
libutempter-1.1.5-4.1.el6.x86_64
cryptsetup-luks-libs-1.2.0-7.el6.x86_64
vim-minimal-7.2.411-1.8.el6.x86_64
libtasn1-2.3-3.el6_2.1.x86_64
net-tools-1.60-110.el6_2.x86_64
pyparsing-1.5.6-1.el6.noarch
db4-utils-4.7.25-17.el6.x86_64
python-cliff-1.4.4-1.el6.noarch
e2fsprogs-1.41.12-14.el6.x86_64
gnutls-utils-2.8.5-10.el6.x86_64
diffutils-2.8.1-28.el6.x86_64
python-warlock-0.4.0-2.el6.noarch
m4-1.4.13-5.el6.x86_64
numad-0.5-8.20121015git.el6.x86_64
dash-0.5.5.1-4.el6.x86_64
librdmacm-1.0.17-0.git4b5c1aa.el6.x86_64
groff-1.18.1.4-21.el6.x86_64
fontconfig-2.8.0-3.el6.x86_64
coreutils-libs-8.4-19.el6.x86_64
perl-DBD-MySQL-4.013-3.el6.x86_64
cracklib-2.8.16-4.el6.x86_64
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
coreutils-8.4-19.el6.x86_64
novnc-0.4-8.el6.noarch
module-init-tools-3.9-21.el6.x86_64
flac-1.2.1-6.1.el6.x86_64
redhat-logos-60.0.14-1.el6.noarch
libsndfile-1.0.20-5.el6.x86_64
libpciaccess-0.13.1-2.el6.x86_64
python-pygments-1.1.1-1.el6.noarch
alsa-lib-1.0.22-3.el6.x86_64
ebtables-2.0.9-6.el6.x86_64
nss-sysinit-3.14.0.0-12.el6.x86_64
cvs-1.11.23-15.el6.x86_64
openldap-2.4.23-31.el6.x86_64
kernel-2.6.32-358.123.2.openstack.el6.x86_64
passwd-0.77-4.el6_2.2.x86_64
openvswitch-1.11.0_8ce28d-1.el6ost.x86_64
mingetty-1.08-5.el6.x86_64
cyrus-sasl-md5-2.1.23-13.el6_3.1.x86_64
krb5-libs-1.10.3-10.el6.x86_64
httpd-2.2.15-26.el6.x86_64
libssh2-1.4.2-1.el6.x86_64
mod_wsgi-3.2-3.el6.x86_64
gnupg2-2.0.14-4.el6.x86_64
ConsoleKit-libs-0.4.1-3.el6.x86_64
curl-7.19.7-35.el6.x86_64
python-paste-1.7.4-2.el6.noarch
rpm-4.8.0-32.el6.x86_64
crudini-0.3-2.el6.noarch
mysql-libs-5.1.66-2.el6_3.x86_64
fipscheck-1.2.0-7.el6.x86_64
libsemanage-2.0.43-4.2.el6.x86_64
newt-0.52.11-3.el6.x86_64
libffi-3.0.5-3.2.el6.x86_64
python-2.6.6-36.el6.x86_64
newt-python-0.52.11-3.el6.x86_64
python-simplejson-2.0.9-3.1.el6.x86_64
pygobject2-2.20.0-5.el6.x86_64
m2crypto-0.20.2-9.el6.x86_64
python-dmidecode-3.10.13-1.el6.x86_64
python-gudev-147.1-4.el6_0.1.x86_64
yum-metadata-parser-1.1.2-16.el6.x86_64
python-pycurl-7.19.0-8.el6.x86_64
yum-3.2.29-40.el6.noarch
rhnlib-2.5.22-12.el6.noarch
dmidecode-2.11-2.el6.x86_64
kbd-misc-1.15-11.el6.noarch
policycoreutils-2.0.83-19.30.el6.x86_64
util-linux-ng-2.17.2-12.9.el6.x86_64
udev-147-2.46.el6.x86_64
device-mapper-1.02.77-9.el6.x86_64
openssh-5.3p1-84.1.el6.x86_64
lvm2-libs-2.02.98-9.el6.x86_64
plymouth-0.8.3-27.el6.x86_64
dracut-004-303.el6.noarch
rsyslog-5.8.10-6.el6.x86_64
cyrus-sasl-2.1.23-13.el6_3.1.x86_64
crontabs-1.10-33.el6.noarch
cronie-1.4.4-7.el6.x86_64
usermode-1.102-3.el6.x86_64
rhn-setup-1.0.0.1-4.el6.noarch
rhn-check-1.0.0.1-4.el6.noarch
dhclient-4.1.1-34.P1.el6.x86_64
system-config-firewall-base-1.2.27-5.el6.noarch
ntp-4.2.4p8-3.el6.x86_64
openssh-server-5.3p1-84.1.el6.x86_64
parted-2.1-19.el6.x86_64
iwl5150-firmware-8.24.2.2-1.el6.noarch
iwl6050-firmware-41.28.5.1-2.el6.noarch
iwl6000g2a-firmware-17.168.5.3-1.el6.noarch
iwl6000-firmware-9.221.4.1-1.el6.noarch
quota-3.17-18.el6.x86_64
grub-0.97-81.el6.x86_64
bind-utils-9.8.2-0.17.rc1.el6.x86_64
sudo-1.8.6p3-7.el6.x86_64
pciutils-3.1.10-2.el6.x86_64
audit-2.2-2.el6.x86_64
efibootmgr-0.5.4-10.el6.x86_64
tmpwatch-2.9.16-4.el6.x86_64
bc-1.06.95-1.el6.x86_64
acl-2.2.49-6.el6.x86_64
attr-2.4.44-7.el6.x86_64
setserial-2.17-25.el6.x86_64
ql2400-firmware-5.08.00-1.el6.noarch
ql2100-firmware-1.19.38-3.1.el6.noarch
libertas-usb8388-firmware-5.110.22.p23-3.1.el6.noarch
ql2500-firmware-5.08.00-1.el6.noarch
zd1211-firmware-1.4-4.el6.noarch
rt61pci-firmware-1.2-7.el6.noarch
ql2200-firmware-2.02.08-3.1.el6.noarch
openstack-swift-proxy-1.8.0-2.el6.noarch
openstack-swift-object-1.8.0-2.el6.noarch
openstack-swift-container-1.8.0-2.el6.noarch
openstack-selinux-0.1.2-11.el6.noarch
numpy-1.4.1-9.el6.x86_64
memcached-1.4.4-3.el6.x86_64
nagios-plugins-ping-1.4.16-5.el6.x86_64
nrpe-2.14-3.el6.x86_64
xinetd-2.3.14-38.el6.x86_64
wget-1.12-1.8.el6.x86_64
epel-release-6-8.noarch
dnsmasq-utils-2.48-13.el6.x86_64
python-passlib-1.5.3-1.el6.noarch
python-backports-1.0-3.el6.x86_64
pixman-0.26.2-4.el6.x86_64
selinux-policy-3.7.19-195.el6_4.12.noarch
febootstrap-supermin-helper-3.12-2.el6.x86_64
sysfsutils-2.1.0-7.el6.x86_64
python-markdown-2.0.1-3.1.el6.noarch
pysendfile-2.0.0-3.el6.x86_64
hal-libs-0.5.14-11.el6.x86_64
sgabios-bin-0-0.3.20110621svn.el6.noarch
ConsoleKit-0.4.1-3.el6.x86_64
hdparm-9.16-3.4.el6.x86_64
hal-0.5.14-11.el6.x86_64
compat-readline5-5.2-17.1.el6.x86_64
ruby-1.8.7.352-7.el6_2.x86_64
facter-1.7.3-1.el6.x86_64
ruby-rdoc-1.8.7.352-7.el6_2.x86_64
rubygem-json-1.5.5-1.el6.x86_64
ruby-augeas-0.4.1-1.el6.x86_64
saslwrapper-0.14-1.el6.x86_64
python-qpid-0.14-11.el6_3.noarch
sg3_utils-1.28-4.el6.x86_64
python-sqlalchemy-0.5.5-3.el6_2.noarch
libxcb-1.8.1-1.el6.x86_64
spice-server-0.12.0-12.el6.x86_64
nfs-utils-lib-1.1.5-6.el6.x86_64
PyPAM-0.5.0-12.el6.x86_64
radvd-1.6-1.el6.x86_64
mdadm-3.2.5-4.el6.x86_64
tunctl-1.5-3.el6.x86_64
genisoimage-1.1.9-12.el6.x86_64
python-django-compressor-1.2-4.el6.noarch
libselinux-ruby-2.0.94-5.3.el6.x86_64
seabios-0.6.1.2-26.el6.x86_64
gettext-0.17-16.el6.x86_64
openstack-swift-plugin-swift3-1.0.0-0.20120711git.el6.noarch
nc-1.84-22.el6.x86_64
libvirt-python-0.10.2-18.el6.x86_64
libX11-common-1.5.0-4.el6.noarch
libXext-1.3.1-2.el6.x86_64
libXtst-1.2.1-2.el6.x86_64
libXpm-3.5.10-2.el6.x86_64
vgabios-0.6b-3.7.el6.noarch
python-urllib3-1.5-5.el6.noarch
python-keystoneclient-0.2.3-7.el6.noarch
python-novaclient-2.13.0-1.el6.noarch
python-django-openstack-auth-1.0.7-1.el6.noarch
python-mako-0.5.0-5.el6.noarch
python-quantum-2013.1.3-1.el6.noarch
python-migrate-0.6-6.el6.noarch
openstack-quantum-2013.1.3-1.el6.noarch
python-nova-2013.1.3-2.el6.noarch
libusb1-1.0.9-0.6.rc1.el6.x86_64
qemu-img-0.12.1.2-2.355.el6.x86_64
python-cinder-2013.1.3-1.el6.noarch
libconfig-1.3.2-1.1.el6.x86_64
libguestfs-1.16.34-2.el6.x86_64
libguestfs-tools-c-1.16.34-2.el6.x86_64
openstack-cinder-2013.1.3-1.el6.noarch
openstack-nova-conductor-2013.1.3-2.el6.noarch
openstack-nova-cert-2013.1.3-2.el6.noarch
openstack-nova-scheduler-2013.1.3-2.el6.noarch
openstack-quantum-openvswitch-2013.1.3-1.el6.noarch
openstack-dashboard-2013.1.3-1.el6.noarch
ipw2100-firmware-1.3-11.el6.noarch
setup-2.8.14-20.el6.noarch
openstack-swift-account-1.8.0-2.el6.noarch
puppetlabs-release-6-7.noarch
ca-certificates-2010.63-3.el6_1.5.noarch
mysql-server-5.1.66-2.el6_3.x86_64
perl-libs-5.10.1-129.el6.x86_64
glibc-2.12-1.107.el6.x86_64
nmap-5.51-2.el6.x86_64
perl-5.10.1-129.el6.x86_64
libcap-2.16-5.5.el6.x86_64
yum-utils-1.1.30-14.el6.noarch
python-sqlalchemy0.7-0.7.8-1.el6.x86_64
popt-1.13-7.el6.x86_64
openstack-packstack-2013.1.1-0.29.dev683.el6.noarch
python-oslo-config-1.1.0-1.el6.noarch
db4-4.7.25-17.el6.x86_64
yum-plugin-downloadonly-1.1.30-14.el6.noarch
python-eventlet-0.9.17-2.el6.noarch
glib2-2.22.5-7.el6.x86_64
python-cinderclient-1.0.4-1.el6.noarch
nss-util-3.14.0.0-2.el6.x86_64
apr-util-1.3.9-3.el6_0.1.x86_64
libxml2-2.7.6-8.el6_3.4.x86_64
avahi-libs-0.6.25-12.el6.x86_64
sqlite-3.6.20-1.el6.x86_64
yajl-1.0.7-3.el6.x86_64
file-libs-5.04-15.el6.x86_64
python-django-appconf-0.5-3.el6.noarch
libblkid-2.17.2-12.9.el6.x86_64
perl-DBI-1.609-4.el6.x86_64
lua-5.1.4-4.1.el6.x86_64
php-common-5.3.3-22.el6.x86_64
dbus-glib-0.86-5.el6.x86_64
lzop-1.02-0.9.rc1.el6.x86_64
e2fsprogs-libs-1.41.12-14.el6.x86_64
boost-program-options-1.41.0-11.el6_1.2.x86_64
pciutils-libs-3.1.10-2.el6.x86_64
libevent-1.4.13-4.el6.x86_64
libgcrypt-1.4.5-9.el6_2.2.x86_64
python-lxml-2.2.3-1.1.el6.x86_64
file-5.04-15.el6.x86_64
python-stevedore-0.11-1.el6.noarch
xz-4.999.9-0.3.beta.20091007git.el6.x86_64
boost-system-1.41.0-11.el6_1.2.x86_64
upstart-0.6.5-12.el6.x86_64
cryptsetup-luks-1.2.0-7.el6.x86_64
procps-3.2.8-25.el6.x86_64
python-cmd2-0.6.4-7.el6.noarch
libss-1.41.12-14.el6.x86_64
qpid-cpp-client-0.14-22.el6_3.x86_64
binutils-2.20.51.0.2-5.36.el6.x86_64
atlas-3.8.4-2.el6.x86_64
ncurses-5.7-3.20090208.el6.x86_64
libSM-1.2.1-2.el6.x86_64
gzip-1.3.12-18.el6.x86_64
httpd-tools-2.2.15-26.el6.x86_64
pam-1.1.1-13.el6.x86_64
libvorbis-1.2.3-4.el6_2.1.x86_64
plymouth-scripts-0.8.3-27.el6.x86_64
mysql-5.1.66-2.el6_3.x86_64
nss-3.14.0.0-12.el6.x86_64
kernel-firmware-2.6.32-358.123.2.openstack.el6.noarch
libuser-0.56.13-5.el6.x86_64
pytz-2010h-2.el6.noarch
keyutils-libs-1.4-4.el6.x86_64
php-5.3.3-22.el6.x86_64
libcurl-7.19.7-35.el6.x86_64
strace-4.5.19-1.17.el6.x86_64
rpm-libs-4.8.0-32.el6.x86_64
openstack-utils-2013.2-1.el6.1.noarch
fipscheck-lib-1.2.0-7.el6.x86_64
python-backports-ssl_match_hostname-3.2-0.5.a3.el6.noarch
slang-2.2.1-1.el6.x86_64
selinux-policy-targeted-3.7.19-195.el6_4.12.noarch
python-libs-2.6.6-36.el6.x86_64
python-chardet-2.0.1-1.el6.noarch
rpm-python-4.8.0-32.el6.x86_64
vconfig-1.9-8.1.el6.x86_64
dbus-python-0.83.0-6.1.el6.x86_64
eggdbus-0.6-3.el6.x86_64
python-rhsm-1.1.8-1.el6.x86_64
pm-utils-1.2.5-10.el6.x86_64
pygpgme-0.1-18.20090824bzr68.el6.x86_64
ruby-libs-1.8.7.352-7.el6_2.x86_64
pyOpenSSL-0.10-2.el6.x86_64
ruby-irb-1.8.7.352-7.el6_2.x86_64
plymouth-core-libs-0.8.3-27.el6.x86_64
hiera-1.2.1-1.el6.noarch
iptables-1.4.7-9.el6.x86_64
python-saslwrapper-0.14-1.el6.x86_64
initscripts-9.03.38-1.el6.x86_64
scsi-target-utils-1.0.24-2.el6.x86_64
device-mapper-event-libs-1.02.77-9.el6.x86_64
pkgconfig-0.23-9.1.el6.x86_64
libdrm-2.4.39-1.el6.x86_64
nfs-utils-1.2.3-36.el6.x86_64
dracut-kernel-004-303.el6.noarch
gpxe-roms-qemu-0.9.7-6.9.el6.noarch
postfix-2.6.6-2.2.el6_1.x86_64
btrfs-progs-0.20-0.2.git91d9eec.el6.x86_64
virt-what-1.11-1.2.el6.x86_64
libasyncns-0.8-1.1.el6.x86_64
yum-rhn-plugin-0.9.1-43.el6.noarch
libgomp-4.4.7-3.el6.x86_64
dhcp-common-4.1.1-34.P1.el6.x86_64
openstack-swift-1.8.0-2.el6.noarch
python-pyasn1-0.0.12a-1.el6.noarch
lvm2-2.02.98-9.el6.x86_64
libXi-1.6.1-3.el6.x86_64
bfa-firmware-3.0.3.1-1.el6.noarch
gd-2.0.35-11.el6.x86_64
b43-openfwwf-5.2-4.el6.noarch
python-requests-1.1.0-4.el6.noarch
iwl1000-firmware-39.31.5.1-1.el6.noarch
python-django-horizon-2013.1.3-1.el6.noarch
ntsysv-1.3.49.3-2.el6.x86_64
python-alembic-0.4.2-3.el6.noarch
alsa-utils-1.0.22-5.el6.x86_64
python-keystone-2013.1.3-2.el6.noarch
psacct-6.3.2-63.el6_3.3.x86_64
openstack-nova-common-2013.1.3-2.el6.noarch
cyrus-sasl-plain-2.1.23-13.el6_3.1.x86_64
qemu-kvm-0.12.1.2-2.355.el6.x86_64
ed-1.1-3.3.el6.x86_64
dosfstools-3.0.9-4.el6.x86_64
redhat-indexhtml-6-1.el6.noarch
openstack-nova-compute-2013.1.3-2.el6.noarch
ivtv-firmware-20080701-20.2.noarch
openstack-nova-console-2013.1.3-2.el6.noarch
atmel-firmware-1.3-7.el6.noarch
openstack-glance-2013.1.3-1.el6.noarch
iwl3945-firmware-15.32.2.9-4.el6.noarch

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Go to top